marleyos/modules/darwin/programs/wireguard/default.nix

20 lines
303 B
Nix

{
lib,
config,
pkgs,
...
}:
let
inherit (lib) mkEnableOption mkIf;
cfg = config.marleyos.programs.wireguard;
in
{
options.marleyos.programs.wireguard.enable = mkEnableOption "wireguard";
config = mkIf cfg.enable {
homebrew.masApps = {
"WireGuard" = 1451685025;
};
};
}